Accueil / Mes interventions / Compaq Presario S7288FR mutliples soucis…

Compaq Presario S7288FR mutliples soucis…

presario-probleme-materiel-multiplesEn voilà un vieux PC ! : Processeur Céleron, disque dur IDE, barrette mémoire en DDR2…Heureusement que la panne est matérielle et non pas logicielle ; je n’aurais pas à réparer-diagnostiquer le système d’exploitation (un Windows Vista) qui s’avère poussif comme l’étaient les PC il y a dix ans, j’ai même droit à ce bruit de frigo -si caractéristique- des antiques disque durs en IDE PATA.

Pour en revenir aux problèmes qui amènent mon client à me contacter, le bouton Power en façade ne fonctionne plus : facile ; il faut juste re-clipser le petit carré qui fait office de switch on-off, placé derrière la façade de l’ordinateur ; l’accès se fait en retirant le panneau latéral gauche du PC. Par prévoyance je rajoute deux point de colle glue (juste ce qu’il faut), les clips ayant perdu leur rigidité.

Deuxième soucis ; au démarrage, le PC affiche un message en texte blanc sur fond noir (le POST pour les connaisseurs). Ce message affiche « bios checksum error », la suite explique que, le BIOS étant corrompu, une restauration de celui va se lancer. Un autre message montre que le bios original n’est pas trouvé, ni sur la disquette, ni sur le CD (ce qui est normal car je n’ai rien inséré dans les périphériques de stockage susdits).
Que faire dans ce cas de BIOS corrompu? Et bien j’ai déconnecté tout ce qui est branché au PC et qui n’est pas utile, aussi  bien les éléments externes (souris USB) que les internes (lecteur disquette, lecteur CD). Le PC est « dans sa plus simple expression » : seuls l’alimentation électrique, le processeur, la carte mère, une seule barrette mémoire, le disque dur système et un clavier PS/2 sont reliés.

De plus après avoir éteint le PC et débranché le câble d’alimentation électrique, je reste appuyé sur le bouton Power durant 1 minute, histoire de vider les condos et autres éléments électroniques de toute charge électrique résiliente. Je fais cela en ayant préalablement retiré la pile bouton de la carte mère bien sûr.

Puis je démarre PC et aboutit à l’ouverture de session (Vista) après une longue et anormale attente au niveau du POST. J’en profite pour accéder à Internet et rapatrier depuis le support HP-Compaq un BIOS heureusement auto-exécutable sous Windows (pas la peine de créer une disquette donc), que je lance. Un redémarrage plus tard, la mise à jour du BIOS se fait et tout se passe bien -à part cette latence bizarre au POST.
Là je me dis que la faute en incombe au disque dur ; bingo : je le constate en débranchant le disque dur d’origine et en le remplaçant par un autre de mon stock ; le temps d’attente au POST redevient normal.

disque-dur-pata

disque dur d’origine en PATA (ide) sous Vista.. A dégager car abimé

Cela dit, j’ai remarqué un autre souci ; en bootant sur le CD de réparation Hiren’s boot CD, celui-ci n’aboutit pas en mode « Mini XP » car il est dit à l’écran que des fichiers essentiels n’ont  pu être chargés, hors je sais que mon CD fonctionne et  j’en conclus à un problème de barrette mémoire défectueuse ; en effet, je n’ai plus ce problème après avoir inséré une barrette testée, en remplacement de l’originelle. Un diagnostic avec Memtest me confirme  que la barrette d’origine est HS.

Reste le problème lié au disque dur IDE, je le règle en branchant un deuxième disque dur SATA (la carte mère possède deux port SATA) et clone l’ancien disque dur PATA sur ce nouveau disque, plus rapide et bien plus récent, avec le CD bootable de Acronis TrueImage.

disque-dur-sata

disque dur en SATA utilisé pour cloner et remplacer le disque dur d’origine

C’est OK : le démarrage sous Vista fonctionne à merveille avec une rapidité accrue, que ce soit en temps de démarrage, en utilisation normale du PC (accès Web, ouverture de document) et lors de d’extinction.
Bilan : une barrette mémoire DDR2 1Go : 20€ ; un disque dur SATA de 160 Go : 40€, et la main d’œuvre : 50€.